«

»

Exchange 2010 SP2 Unleashed

In diesem Artikel werde ich das Exchange 2010 SP2 auf einem Exchange Server 2010 SP1 installieren. Zunächst lasse ich mir mit dem Befehl Get-ExchangeServer -Identity <servername> | fl name,*version* die aktuelle Exchange Server Version per Shell anzeigen:
Falls noch nicht geschehen kann man mit dem Befehl regsvr32 schmmgmt.dll die schmmgmt.dll registriegen und somit das Active-Direcotry-Schema-SnapIn hinzufügen um sich die Objekte und Attribute des Active-Directory Schema anzeigen zu lassen:Anschließend können wir uns mit dem ADSI-Editor das Objekt ms-Exch-Schema-Version-Pt anzeigen, dazu rufen wir den ADSI-Editor auf und lassen uns darin den Namenskontext “Schema” anzeigen:
Das Objekt enthält in Exchange Server 2010 SP1 ein Attribut Namens rangeUpper, welches den Wert 14726 besitzt. In der Version Exchange 2010 SP2 besitzt dieses Attribut den Wert 14732, was wir nach dem Update sehen werden.

Wir öffnen im ADSI-Editor zzgl. den Namenskontext Konfiguration und navigieren in diesem Namenskontext zum Container CN=<Organisation>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<domain> In den Eigenschaften des Containers <Organisationname> in diesem Fall CN=mydomain, lassen wir uns das Attribut objectVersion anzeigen, welches den Wert 13214 besitzt, ebenfalls in der Version Exchange Server 2010 SP1. In der Version Exchange Server 2010 SP2 wird dieser Wert 14247 sein. Diese Werte werden wir nach der Installation des Servicepack 2 überprüfen und vergleichen.

Das Servicepack 2 setzt voraus, dass das Windows-Feature IIS-6-WMI-Kompatibilität installiert ist. Falls noch nicht installiert, können wir das im Servermanager oder per Befehl in der Powershell nachholen. Zunächst importieren wir die Module des Servermanager, anschließen installieren wir mit dem Befehl Add-WindowsFeature Web-WMI das entsprechende IIS-Feature:Nun können wir entweder über die Konsole das Setup durchführen oder aber per Eingabeaufforderung oder Powershell. Hierbei wird auch, falls nicht manuell geschehen, ein Schema-Update ausgeführt, welches das Schema zzgl. um Objekte und Attribute erweitert. Wichtig ist hierbei anzumerken, dass bei jeglicher Ausführung, ob über die Setup-Konsole, als auch über die Shell, das Setupgeschehen im ExchangeSetup.log festgehalten wird, welche sich standardmäßig unter C:\ExchangeSetupLogs befinden. Hier kann man gut verfolgen, welche Installationsschritte gerade ablaufen, ob es zu Fehlern gekommen ist oder, ob Dienste nicht gestartet werden können etc…

Ich möchte zunächst das Schema manuell updaten, deswegen öffne ich den Pfad indem die Exchange 2010 Sp2 Setupdateien extrahiert worden sind, öffne die Eingabeaufforderung und gebe setup /ps (oder setup /prepareSchema) ein. Das Geschehen verfolge ich im ExchangeSetup.log:Im ExchangeSetupLog wird uns unter anderem die aktuelle Exchange 2010 Sp1 Version angezeigt, die Version des Exchange 2010 SP2, welcher Domaincontroller verwendet wird, welche Serverrollen installiert sind etc. und ob ein Schema Update oder Organisationsupdate (Active-Directory) erforderlich ist…

Rufe ich das Setup in der Eingabeaufforderung mit dem Befehl setup /p (oder setup /prepareAD) erneut auf, um das Active-Directory zu erweitern, wird festgestellt, dass bereits ein Schema-Update durchgeführt worden – aber das Update der Organisation noch erforderlich ist…Nachdem die Updates manuell installiert worden sind können wir mit der Installation fortfahren. Wir können nun zur Installation den Weg über die Konsole der Setuproutine wählen……oder aber über die Shell oder Eingabeaufforderung. Ich wähle hier weiterhin den Weg über die Eingabeaufforderung, indem ich vorab in das Verzeichnis der extrahierten Setupdateien wechsel und mit dem Befehl setup -mode:updgrade das Exchange 2010 SP2 als Upgrade ausführe:Wiederum können wir uns im ExchangeSetup.log das Installationsgeschehen anzeigen lassen und erkennen diesmal, dass kein Schema- oder Organisationsupdate erforderlich ist:

Ab und zu kann es vorkommen, dass das Setup nicht weiter fortgeführt wird, schauen Sie deshalb bei Stillstand in das ExchangeSetup.log um den Fehler zu lokalisieren. Es kann vorkommen, dass ein Dienst nicht rechtzeitig gestartet wird, versuchen Sie in diesem Fall den Dienst manuell zu starten, damit das Setup weiter voranschreitet.

Nach der Installation und einem Neustart des Exchange Servers lassen wir uns erneut mit der Shell mit dem Befehl Get-ExchangeServer -identity <servername> | fl name,*version* die Exchange Version anzeigen und sehen, dass die Version nun den Wert 14.2 (Build 247.5) besitzt:Zum Schluss öffnen wir erneut den ADSI-Editor und lassen uns im Namenskontext Schema das Objekt ms-Exch-Schema-Version-Pt anzeigen, welches nun das Attribut rangeUpper mit dem Wert 14732 besitzt:Zusätzlich öffnen wir den Namenskontext Konfiguration und navigieren erneut zum Container CN=<Organisation>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<domain>, öffnen die Eigenschaften des Containers und lassen uns das Attribut objectVersion anzeigen, welches nun den Wert 14247 besitzt:

…Ganz zum Schluss ein kleiner Blick auf Outlook Mobile Access, Anwender dürfen sich nun freuen ;-)

 

 

 

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Sie können diese HTML-Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

4 Besucher online
1 Gäste, 3 Bots, 0 Mitglied(er)
Meiste Besucher heute: 7 um/am 03:03 am UTC
Diesen Monat: 31 um/am 11-10-2017 09:41 am UTC
Dieses Jahr: 40 um/am 03-24-2017 10:19 pm UTC
Jederzeit: 121 um/am 04-18-2012 10:15 am UTC